LCGB Forums

The ability to post messages is restricted to LCGB members. Any questions contact us at lcgbadmin@googlemail.com

Casatronic Timing / Strobe Gun Issue?

Technical help for Series one, two and three Lambrettas. Models include the Li, Li Special, TV, SX, GP, Serveta and API/SIL models

Casatronic Timing / Strobe Gun Issue?

Postby nsaints » Sat Feb 15, 2020 11:32 am

Sanity check required :?

I have watched the Casa video how to fit and time my casatronic ignition
I have marked my mag housing at 24 and 16 degrees BTDC, with the expectation at fast tickover I set the timing to 24, and then as revs rising the firing point advances to 16

I'm also aware with this ignition there are two sparks per revolution, 180 degrees apart

At fast tick-over my strobe indicates the mark on the flywheel correctly in relation to the 24 degree mark on the mag housing

However as revs rise, instead of the flywheel mark advancing towards 16, it completely vanishes !

The marking at 180 firing point remains visible at all times - the engine sounds clean still (indicating it must still be firing between 24/16 BTDC

anyone else seen this issue
This must mean my strobe is knackered - would you agree?
User avatar
nsaints
 
Posts: 41
Joined: Fri May 30, 2014 8:08 pm
Location: Oxford

Re: Casatronic Timing / Strobe Gun Issue?

Postby CHRIS in MARGATE » Sat Feb 15, 2020 12:45 pm

It retards, not advances. Is your clamp on your strobe directional? Weird and alarming if timing mark disappears ! It must be somewhere.
User avatar
CHRIS in MARGATE
 
Posts: 4074
Joined: Fri May 30, 2014 5:49 pm

Re: Casatronic Timing / Strobe Gun Issue?

Postby nsaints » Sat Feb 15, 2020 1:48 pm

yep, sorry

Drove and got my mates strobe gun, no issues using his

Mine must be faulty and only flashing on one signal through the HT
User avatar
nsaints
 
Posts: 41
Joined: Fri May 30, 2014 8:08 pm
Location: Oxford


Return to Series 1, 2 & 3

Who is online

Users browsing this forum: Google [Bot] and 17 guests