LCGB Forums

The ability to post messages is restricted to LCGB members. Any questions contact us at lcgbadmin@googlemail.com

Engine won't Rev.... Help!

Want to know which carb to choose? Having problems setting up the jetting details on your scooter? Wheter you are using a standard or tuned carb, ask your question here.

Engine won't Rev.... Help!

Postby Hughieboy » Fri Jul 10, 2015 8:00 pm

Evening All,

I've just stripped and rebuilt the top end and added a 30mm phbh Dellorto and TSR EVO exhaust. I've matched the exterior porting to the new manifolds. Scooter is a Harry Barlow/Suzuki 190 conversion. Carb came from Cam Lam with ball park jetting. All was good and it went well straight off the bat, plug colour looked fine etc...

The other night, all of a sudden it started to die, I eased off the throttle and it remained running at low revs but died whenever I tried to open it up. Since then I have stripped the carb to check for blockages and the jets are clear. The rubber mount is fine and not split. I have replaced the ignition switch as this needed doing anyway. Fuel is flowing (new Cam Lam fast flow tap), petrol cap vent is not blocked.

Still it does the same, it's ok for about 200 yards then starts dying again. I have changed the plug. The plug cap is new as is the lead. Choke is not sticking. I did a leak down test when I assembled it. I'm at a loss to know what to look for next, has anyone got any ideas?

Spoke to Cam Lam and they said the jetting may not be spot on but it should be near enough as they've sent it jetted the same as they do for their Imola kits.

It's almos like fuel isnt get through but it must be, take the foam filter off and there's plenty spitting back out but it just won't rev.

I'd be really grateful if anyone could shed any light on what to try next, supposed to be going to a rally for the day tomorrow and I've run out of ideas!

Thanks in advance....
User avatar
Hughieboy
 
Posts: 159
Joined: Tue Jun 17, 2014 7:15 am

Re: Engine won't Rev.... Help!

Postby Norrie Bodge » Fri Jul 10, 2015 10:51 pm

a longshot ? but happened to me yrs ago going to Gt Yarmouth

the needle is lifting as you rev it? the slide needle clip hasnt came off by chance??
Norrie Bodge
 
Posts: 422
Joined: Sat Aug 16, 2014 3:34 pm

Re: Engine won't Rev.... Help!

Postby Hughieboy » Fri Jul 10, 2015 10:55 pm

Norrie Bodge wrote:a longshot ? but happened to me yrs ago going to Gt Yarmouth

the needle is lifting as you rev it? the slide needle clip hasnt came off by chance??


That's one thing I haven't checked but I'll check....! Thanks for the heads up, will let you know :)
User avatar
Hughieboy
 
Posts: 159
Joined: Tue Jun 17, 2014 7:15 am

Re: Engine won't Rev.... Help!

Postby Hughieboy » Sat Jul 11, 2015 8:32 am

Needles working fine..... Starting to think it could be electrical/ignition related....
User avatar
Hughieboy
 
Posts: 159
Joined: Tue Jun 17, 2014 7:15 am

Re: Engine won't Rev.... Help!

Postby johnnyXS » Sat Jul 11, 2015 10:14 am

if you have no air leaks around the carb or inlet ,...from the symptoms you describe it sounds like it might be a short somewhere between the ignition coil on the stator (green wire) and the HT coil or from the rear junction box to the on/off switch .
Might be worth removing the stator and checking the coil wiring where it exits the stator housing and also behind the headset and look for crimped or chafed wires etc ;)

The easiest way to check the ignition circuit without removing the stator would be to pull all the wires wires out the rear junction box and connect just the green wire from the stator directly to your HT coil and see if it runs any better. You'll have to pull the green wire off to stop the engine though .
johnnyXS
 
Posts: 969
Joined: Tue Feb 10, 2015 2:00 pm

Re: Engine won't Rev.... Help!

Postby hullygully » Mon Jul 13, 2015 1:34 pm

check the readings off the stator wires too before you remove it
hullygully
 
Posts: 526
Joined: Thu Jun 05, 2014 1:28 pm
Location: Hull

Re: Engine won't Rev.... Help!

Postby johnnyXS » Sat Apr 16, 2016 12:48 pm

hey hughieboy how about an update on this . !
It would be good to know if our advice was helpful and what the issue actually was . ;)
johnnyXS
 
Posts: 969
Joined: Tue Feb 10, 2015 2:00 pm

Re: Engine won't Rev.... Help!

Postby Paul_from_Thornbury » Fri May 27, 2016 12:44 pm

Sounds very familiar to a fault I had, and that was the electronic pickup on the BGM stator, the symptoms were almost identical.

I had a spare BGM which I put in and it did the same thing, speaking with Paul Baker who jetted my lambretta he was convinced it was the pickup.

I bit the bullet and bought another stator and all was resolved. I now have two stators that need a new pickup installing to make good spares.
Paul_from_Thornbury
 
Posts: 103
Joined: Fri Jun 20, 2014 10:32 am

Re: Engine won't Rev.... Help!

Postby johnnyXS » Fri May 27, 2016 12:59 pm

this is a year old now paul so I doubt we'll get a response but looking through Hughieboys other posts it seems he bought and fitted a varioatronic
ignition system which cured the fault . See here
viewtopic.php?t=3853
johnnyXS
 
Posts: 969
Joined: Tue Feb 10, 2015 2:00 pm


Return to Carburettors

Who is online

Users browsing this forum: No registered users and 4 guests